Exemplo n.º 1
0
 /**
  * @param \Box\TestScribe\Execution\ExecutionResult $executionResult
  *
  * @return void
  */
 public function genSpec(ExecutionResult $executionResult)
 {
     // This method assumes that the saved specs have been loaded.
     $specsPerClass = $this->savedSpecs->getSpecPerClass();
     $oneSpec = $this->specDetailRenderer->genSpecDetail($executionResult);
     $methodName = $this->globalComputedConfig->getMethodName();
     $newSpecsPerClass = $this->specsPerClassService->addOneSpec($specsPerClass, $methodName, $oneSpec);
     $this->savedSpecs->saveNewSpec($newSpecsPerClass);
 }