예제 #1
0
 public function __construct(colorizer $colorizer = null, prompt $prompt = null)
 {
     parent::__construct();
     $this->colorizer = $colorizer ?: new colorizer(34);
     $this->prompt = $prompt ?: new prompt('  ∅ ', new colorizer('1;37', 44));
     $this->events = array(test::void);
 }
예제 #2
0
 public function __construct(colorizer $colorizer = null, prompt $prompt = null)
 {
     parent::__construct();
     $this->colorizer = $colorizer ?: new colorizer(32);
     $this->prompt = $prompt ?: new prompt('  ✔ ', new colorizer('1;37', 42));
     $this->events = array(test::success);
 }
예제 #3
0
파일: cli.php 프로젝트: atoum/bdd-extension
 public function __construct()
 {
     parent::__construct();
     $this->events = array(test::runStop, test::runtimeException);
 }
예제 #4
0
 public function __construct(prompt $prompt = null)
 {
     parent::__construct();
     $this->prompt = $prompt ?: new prompt('     Uncompleted:', new colorizer('1;37'));
     $this->events = array(test::uncompleted);
 }