/**
  * isSupportedBy
  *
  * Check this specification is supported
  *
  * @param  string  $entityClassName The name of the entity class
  * @return boolean
  */
 public function isSupportedBy($entityClassName)
 {
     return $this->condition->isSupportedBy($entityClassName);
 }
 /**
  * isSupportedBy
  *
  * Check if this specification is supported by the provided class name
  *
  * @param  string  $className
  * @return boolean
  */
 public function isSupportedBy($className)
 {
     return $this->spec->isSupportedBy($className);
 }