Exemple #1
0
 public function testResponseReturnNullOnEmptyError()
 {
     $response = new Response(1);
     $this->assertNull($response->getError());
     $this->assertNull($response->getErrorCode());
     $this->assertNull($response->getErrorMessage());
     $this->assertNull($response->getErrorData());
 }
Exemple #2
0
 /**
  * @param Response $response
  */
 private function addResponse(Response $response)
 {
     $id = $response->getId();
     if (isset($this->keys[$id])) {
         $this->responses[$this->keys[$id]] = $response;
     }
 }