/**
  * testComparisonTypeIsEqual
  *
  * @test
  */
 public function testComparisionTypeIsEqual()
 {
     $spec = new IsEqual(1, 1);
     $this->assertEquals(IsEqual::EQ, Comparison::EQ);
     $this->assertEquals(IsEqual::EQ, $spec->getOperator());
     $this->assertEquals('=', $spec->getOperator());
 }
 /**
  * __construct
  *
  * @param mixed $id The entity identity
  */
 public function __construct($id, $alias = null)
 {
     if ($id instanceof EntityInterface) {
         $id = $id->getId();
     }
     if (!is_int($id)) {
         throw new InvalidArgumentException(sprintf('The \'id\' argument must be either integer or object of type \'%s\'; \'%s\' given in \'%s\'', EntityInterface::class, is_object($id) ? get_class($id) : gettype($id), __METHOD__));
     }
     parent::__construct(isset($alias) ? $alias . '.id' : 'id', $id);
 }